1
$\begingroup$
from sklearn.neighbors import NearestNeighbors, LSHForest
ImportError: cannot import name 'LSHForest' from 'sklearn.neighbors'

I came to know that LSHForest is depreciated. So how can use it. do we have any other alternative.

I'm using Sklearn version 1.0.1

$\endgroup$

1 Answer 1

0
$\begingroup$

The LSHForest model has indeed been deprecated and remove from scikit-learn. Looking at historical versions it seems that the model has been removed in version 0.21, but was still available in versions before that (even though it was already deprecated). Downgrading your scikit-learn version to 0.20 or before should allow you to still use the model.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.