1
$\begingroup$

I'm trying to get used to text mining using orange. I set up a very easy workflow loading a corpus (tab separated text file containing 10 entries), using a corpus viewer that shows my data correctly and a topic discovery item. But I always receive an error Message at 95% of topic discovery called:

Message: "Error calling '%s' of '%s'"
Arguments: ('set_data', 'Topic Discovery')

What do you think am I doing wrong here? Thank you very much for your help in advance.

Stefan

$\endgroup$
  • $\begingroup$ The title of this post is very vague. Can you be specific about what kind of error you're having? Maybe mention you're using Orange? $\endgroup$ – sheldonkreger May 10 '17 at 20:45
1
$\begingroup$

One thing I've noticed about Orange is that anytime you get an error calling set_data, there will be some sort of ValueError or FormatError that it is a child of.

Take a look at the rest of the errors and look for some type of value or formatting error, or post your full error log in a pastebin so I can take a look.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Which version are you running? Does the same happen on the 0.2.2 version released a few days ago (note that for 0.2.2 you need also the newest version of Orange; i.e 3.3.9)?

It looks like you're not doing anything wrong but rather that this is a bug. If you could paste the whole error log, perhaps also a schema and a sample of the data if possible, along with the version of Orange and Orange3-Text that you are running I promise to take a look and fix the bug.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.