1
$\begingroup$

I have cloudera CDH5 running inside a virtual box.

when I try to run :

mahout spark-itemsimilarity ....

I get the error:

Unknown program 'spark-itemsimilarity' chosen.

Do i have to install any additional package to run the spark-similarity?

Any help would be appreciated !

$\endgroup$
2
  • $\begingroup$ What version of Mahout are you using? I think that Spark job execution supported was provided since Mahout 0.10. $\endgroup$ May 18 '16 at 9:47
  • $\begingroup$ The output of 'rpm -qa | grep mahout' is 'mahout-0.9+cdh5.7.0+29-1.cdh5.7.0.p0.79.el6.noarch'. So I guess Cloudera CDH5.7 comes with Mahout 0.9. Is that right? $\endgroup$ May 18 '16 at 23:48
1
$\begingroup$

Spark support for Mahout came from Mahout 0.10 release while you are using 0.9 release. So this should explain why you get the unknown program error. I would suggest using a higher version of Mahout.

$\endgroup$
1
  • $\begingroup$ Cloudera only ships with 0.9+ however Mahout doesn't require complicated configs. Simply download Mahout and make sure SPARK_HOME is set properly in the env variables and it should work. (better yet- please call your CDH rep, and tell them you want Mahout 0.13.0) $\endgroup$ Jul 16 '17 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.