0
$\begingroup$

I have installed Anaconda and want tor run MWE for MNIST but I'me getting this error:

D:\STAZENE_last\Anaconda2\Lib\site-packages\torch\cuda\__init__.py:107:

UserWarning: CUDA initialization: The NVIDIA driver on your system is too old (found version 9010). Please update your GPU driver by downloading and installing a new version from the URL: http://www.nvidia.com/Download/index.aspx Alternatively, go to: https://pytorch.org to install a PyTorch version that has been compiled with your version of the CUDA driver. (Triggered internally at ..\c10\cuda\CUDAFunctions.cpp:109.) return torch._C._cuda_getDeviceCount() > 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Pytorch requires CUDA to run on Nvidia GPUs, and different versions of CUDA require different device drivers. The error message is telling you to update your device driver, or install a different version of pytorch. You can alternatively install a CPU version of Pytorch using the configuration GUI here: https://pytorch.org/get-started/locally/ by selecting Compute Platform CPU on the last line then running the command generated.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.