0
$\begingroup$

I am currently working on a binary image classification. My problem is that when i use data augmentation, it incorrectly labels the images when it is set to binary.

The things i have tried:

  1. Looked for incorrectly labeled classes on images before augmenting my data. Here is nothing wrong however.
  2. Changed the class mode to categorical. This works, however i am not working on a multi-class classification.
  3. Tried playing with the image data generator. Nothing worked.
  4. Looked for classification imbalances. Also nothing wrong.

What could I try more? Should i just use categorical class mode on my generator?

$\endgroup$
2
  • $\begingroup$ Do you mean the labels of the augmented data are wrong? Or that the predictions become worse? How are you performing the augmentation? $\endgroup$
    – Ben Reiniger
    Apr 15 at 14:04
  • $\begingroup$ I found a solution already, I removed using the imagedatagenerator and used the tf.keras library to augment my dat since imagedatagenerator is deprecated. Then i changed the class mode to categorical. This fixed it for me. $\endgroup$
    – Enes Aygun
    Apr 16 at 15:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.