2
$\begingroup$

I am trying to install an Add-on package from GitHub that contains prototype widgets for Orange Data Mining. I am trying to install it from the GitHub page found here.

I am using the following Terminal code to install this:

git clone http://github.com/biolab/orange3-prototypes.git

Everything then appears to install correctly and the download shows 100%. Then, however, it throws an error and says:

Orange requires Python >= 3.4

I am using Mac OS. Clearly, it is suggesting that I need to use a different version of python to install, however, I already updated my pip install. Any insight into how I can fix this?

$\endgroup$
0
3
$\begingroup$

The error message shows exactly what you need to do:

Orange requires Python>=3.4

You have to specify a Python>=3.4 version (with orange3 itself installed) while installing orange3-prototypes.

I'm not a Mac user, however, in Windows, Orange3 installer will automatically install a Python 3.4 if there's no compatible Python available.

$\endgroup$
1
  • 5
    $\begingroup$ Use pip3 instead of pip. $\endgroup$
    – K3---rnc
    Feb 28 '17 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.