2
$\begingroup$

This question already has an answer here:

enter image description here

Trying to integrate some prototype widgets into Orange Data Mining to do some machine learning with facial recognition. Trying to install the package from https://github.com/biolab/orange3-prototypes.git but when I type this into my Terminal (I am using Mac OS) I keep getting this error message. I just updated my pip install and am not sure what to do. Any advice helps! Thanks.

$\endgroup$

marked as duplicate by Icyblade, Stereo, Sean Owen Feb 28 '17 at 22:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2
$\begingroup$

The error message shows exactly what you need to do:

Orange requires Python>=3.4

You have to specify a Python>=3.4 version (with orange3 itself installed) while installing orange3-prototypes.

I'm not a Mac user, however, in Windows, orange3 installer will automatically install a Python 3.4 if there's no compatible Python available.

$\endgroup$
  • 3
    $\begingroup$ Use pip3 instead of pip. $\endgroup$ – K3---rnc Feb 28 '17 at 21:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.