4
$\begingroup$

Hello everyone I'm having a weird problem.

I having problem with one of two models I've been using. Models take an image data as input and outputs joystick and keyboard information.

  • A simple CNN, implemented using Keras to use with MNIST data, in which I changed the input size;
  • The inception_v3 (which is way more complex than the first one).

While training the first model, it throws the following error:

> 2018-05-07 23:03:22.080446: W T:\src\github\tensorflow\tensorflow\core\framework\allocator.cc:101] Allocation of 1037238272 exceeds 10% of system memory.

I have tried changing the batch_size parameter to a smaller batch size without any results.

$\endgroup$
  • $\begingroup$ Your problem is with the cnn which is using MNIST? $\endgroup$ – Media May 8 '18 at 14:40
  • $\begingroup$ No. I'm using image data ->X and input of joystick and keyboard->Y. $\endgroup$ – Manu May 8 '18 at 14:50
  • $\begingroup$ I tried in linux and it freeze but can go on after a while, so I don't know if it is because of Windows (where I was trying) or the way that keras manages the memory and data... $\endgroup$ – Manu May 8 '18 at 14:52
  • $\begingroup$ Have you used your image data as the input of the architecture of the second link? Have you reshaped your input? if so to which size? $\endgroup$ – Media May 8 '18 at 15:05
  • 2
    $\begingroup$ If you have not resized your input image, since you have few numbers of convolution and pooling layer, the number of parameters in your dense layers can be a huge number because the outputs of convolutional layers will have a lot of activation maps. $\endgroup$ – Media May 8 '18 at 15:19