-3
$\begingroup$

I'm trying to do some intent extraction/recognition. I've installed all dependancies (I believe) but it still gives me the error:

File "C:\Users\user\.spyder-py3\chatbot\Outlook\rasa_nlu\components.py", line 65, in validate_requirements
    "Please install {}".format(", ".join(failed_imports)))

Exception: Not all required packages are installed. To use this pipeline, 
you need to install the missing dependencies. Please install
sklearn_crfsuite, spacy

Can someone please share their knowledge on how I can resolve this?

Here is my pip list:

absl-py (0.1.13)
asciitree (0.3.3)
asn1crypto (0.24.0)
astor (0.6.2)
atomicwrites (1.1.5)
attrs (18.1.0)
Automat (0.6.0)
beautifulsoup4 (4.6.0)
bleach (1.5.0)
boto (2.48.0)
boto3 (1.5.20)
botocore (1.8.50)
bz2file (0.98)
certifi (2018.4.16)
cffi (1.11.5)
chardet (3.0.4)
cloudpickle (0.5.2)
colorama (0.3.9)
coloredlogs (9.0)
conda (4.4.10)
constantly (15.1.0)
cryptography (2.1.4)
cycler (0.10.0)
cymem (1.31.2)
Cython (0.27.2)
cytoolz (0.8.2)
decorator (4.2.1)
dill (0.2.8.2)
docutils (0.14)
duckling (1.8.0)
en-core-web-md (2.0.0)
en-core-web-sm (2.0.0)
et-xmlfile (1.0.1)
ftfy (4.4.3)
future (0.16.0)
gast (0.2.0)
gensim (3.4.0)
gevent (1.2.2)
gitdb2 (2.0.3)
GitPython (2.1.9)
greenlet (0.4.13)
grpcio (1.10.0)
html5lib (1.0.1)
humanfriendly (4.12.1)
hyperlink (17.3.1)
idna (2.6)
incremental (17.5.0)
jdcal (1.3)
jmespath (0.9.3)
JPype1 (0.6.3)
jsonschema (2.6.0)
kiwisolver (1.0.1)
klein (17.10.0)
koala2 (0.0.17)
lxml (4.2.2)
Markdown (2.6.11)
matplotlib (2.1.0)
menuinst (1.4.11)
mkl-fft (1.0.0)
mkl-random (1.0.1)
mock (2.0.0)
more-itertools (4.2.0)
msgpack-numpy (0.4.1)
msgpack-python (0.5.4)
murmurhash (0.28.0)
networkx (1.9)
nltk (3.2.5)
numpy (1.14.0)
oauthlib (2.0.7)
openpyxl (2.4.9)
packaging (17.1)
pandas (0.22.0)
pandas-datareader (0.6.0+21.gda18fbd)
pathlib (1.0.1)
pbr (4.0.4)
pip (9.0.1)
plac (0.9.6)
pluggy (0.6.0)
preshed (1.0.0)
protobuf (3.5.2.post1)
py (1.5.4)
py4j (0.10.6)
pyasn1 (0.4.3)
pyasn1-modules (0.2.2)
pycosat (0.6.3)
pycparser (2.18)
pynput (1.3.10)
pyOpenSSL (17.5.0)
pyparsing (2.2.0)
pyreadline (2.1)
PySocks (1.6.7)
pyspark (2.3.0)
pytest (3.6.2)
python-crfsuite (0.9.5)
python-dateutil (2.7.2)
pytz (2018.4)
pywin32 (223)
PyYAML (3.12)
rasa-nlu (0.13.0a2, c:\users\users\rasa_nlu)
regex (2017.4.5)
requests (2.18.4)
requests-file (1.4.3)
requests-ftp (0.3.1)
requests-oauthlib (0.8.0)
ruamel-yaml (0.15.35)
s3transfer (0.1.13)
scikit-learn (0.19.1)
scipy (1.1.0)
selenium (3.11.0)
service-identity (17.0.0)
setuptools (38.4.0)
simplejson (3.13.2)
six (1.11.0)
sklearn-crfsuite (0.3.6)
smart-open (1.5.7)
smmap2 (2.0.3)
spacy (2.0.11)
tabulate (0.8.2)
tensorboard (1.7.0)
tensorflow (1.7.0)
termcolor (1.1.0)
textblob (0.15.1)
thinc (6.10.2)
toolz (0.9.0)
tqdm (4.19.5)
tweepy (3.6.0)
Twisted (18.4.0)
typing (3.6.2)
ujson (1.35)
urllib3 (1.22)
wcwidth (0.1.7)
webencodings (0.5.1)
Werkzeug (0.14.1)
wheel (0.30.0)
win-inet-pton (1.0.1)
wincertstore (0.2)
wrapt (1.10.11)
xlrd (1.1.0)
XlsxWriter (1.0.2)
zope.interface (4.5.0)
$\endgroup$
1
  • $\begingroup$ You can accept your answer, so that the question wont pop again. $\endgroup$ Jul 4 '18 at 13:48
0
$\begingroup$

I found an answer that actually ended up helping me from GitHub. Unfortunately I just lost the link. But here is the code I used. It basically kept telling me which dependencies were still missing. I'm not sure how they weren't captured in the install...but I was able to get them and put them in the lib.

import importlib
package='spacy'
importlib.import_module(package)
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.