2
$\begingroup$

I am trying to install the Text add-on for Orange, and I am getting the following error on my Macbook. What's interesting is that I was able to install this plugin on my Windows10 workstation.

enter image description here

And the error details:

Collecting Orange3-Text
Collecting biopython (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/6a/22/c5b6e425d7ed86a52fe10be670b95513b43e0853908d70a984d9a68a9945/biopython-1.72-cp36-cp36m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl
Collecting wikipedia (from Orange3-Text)
Collecting lxml (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/e4/e4/75453295abd6dcd8f7b48c1eb092ce2c23c34ae08ca7acc8c42de35a5a78/lxml-4.2.5-cp36-cp36m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl
Collecting nltk>=3.0.5 (from Orange3-Text)
Collecting odfpy>=1.3.5 (from Orange3-Text)
Collecting simhash (from Orange3-Text)
Requirement already satisfied: scikit-learn in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3-Text)
Collecting setuptools-git (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/05/97/dd99fa9c0d9627a7b3c103a00f1566d8193aca8d473884ed258cca82b06f/setuptools_git-1.2-py2.py3-none-any.whl
Collecting beautifulsoup4 (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/21/0a/47fdf541c97fd9b6a610cb5fd518175308a7cc60569962e776ac52420387/beautifulsoup4-4.6.3-py3-none-any.whl
Requirement already satisfied: scipy in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3-Text)
Collecting gensim>=0.12.3 (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/62/19/8ecba86351de0eacb9baf1cc49ba86315cd91bc672acd74d6e4e709eb482/gensim-3.6.0-cp36-cp36m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl
Collecting ufal.udpipe (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/f7/20/9fdf23855a8dbb018b91f798d5923fd3aadff5d1d8bee39187973f8e17bc/ufal.udpipe-1.2.0.1.tar.gz
Collecting pdfminer3k>=1.3.1 (from Orange3-Text)
Collecting validate-email (from Orange3-Text)
Requirement already satisfied: numpy in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3-Text)
Collecting tweepy (from Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/05/f1/2e8c7b202dd04117a378ac0c55cc7dafa80280ebd7f692f1fa8f27fd6288/tweepy-3.6.0-py2.py3-none-any.whl
Requirement already satisfied: Orange3>=3.4.3 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3-Text)
Collecting docx2txt>=0.6 (from Orange3-Text)
Requirement already satisfied: requests<3.0.0,>=2.0.0 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from wikipedia->Orange3-Text)
Requirement already satisfied: six in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from nltk>=3.0.5->Orange3-Text)
Collecting smart-open>=1.2.1 (from gensim>=0.12.3->Orange3-Text)
Collecting pytest>=2.0 (from pdfminer3k>=1.3.1->Orange3-Text)
  Downloading https://files.pythonhosted.org/packages/0c/9a/592314ceda78f3307afb6cf56d7fdbb92c5a5960a88a6d2fd25c11312ead/pytest-3.8.1-py2.py3-none-any.whl (209kB)
Collecting ply>=3.4 (from pdfminer3k>=1.3.1->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/a3/58/35da89ee790598a0700ea49b2a66594140f44dec458c07e8e3d4979137fc/ply-3.11-py2.py3-none-any.whl
Collecting PySocks>=1.5.7 (from tweepy->Orange3-Text)
Collecting requests-oauthlib>=0.7.0 (from tweepy->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/94/e7/c250d122992e1561690d9c0f7856dadb79d61fd4bdd0e598087dce607f6c/requests_oauthlib-1.0.0-py2.py3-none-any.whl
Requirement already satisfied: AnyQt>=0.0.8 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: bottleneck>=1.0.0 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: chardet>=3.0.2 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: docutils in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: joblib>=0.9.4 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: keyring in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: keyrings.alt in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: matplotlib>=2.0.0 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: networkx in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: pip>=9.0 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: pyqtgraph>=0.10.0 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: python-louvain in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: serverfiles in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: setuptools>=36.3 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: xlrd>=0.9.2 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: urllib3<1.24,>=1.21.1 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from requests<3.0.0,>=2.0.0->wikipedia->Orange3-Text)
Requirement already satisfied: idna<2.8,>=2.5 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from requests<3.0.0,>=2.0.0->wikipedia->Orange3-Text)
Requirement already satisfied: certifi>=2017.4.17 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from requests<3.0.0,>=2.0.0->wikipedia->Orange3-Text)
Collecting boto3 (from smart-open>=1.2.1->gensim>=0.12.3->Orange3-Text)
  Downloading https://files.pythonhosted.org/packages/f5/b4/7c6af5f0574397c74e3c40dba733733f5ed086ab3dd49bf3008b6e9b3dc6/boto3-1.9.10-py2.py3-none-any.whl (128kB)
Collecting boto>=2.32 (from smart-open>=1.2.1->gensim>=0.12.3->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/23/10/c0b78c27298029e4454a472a1919bde20cb182dab1662cec7f2ca1dcc523/boto-2.49.0-py2.py3-none-any.whl
Collecting bz2file (from smart-open>=1.2.1->gensim>=0.12.3->Orange3-Text)
Collecting attrs>=17.4.0 (from pytest>=2.0->pdfminer3k>=1.3.1->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/3a/e1/5f9023cc983f1a628a8c2fd051ad19e76ff7b142a0faf329336f9a62a514/attrs-18.2.0-py2.py3-none-any.whl
Collecting pluggy>=0.7 (from pytest>=2.0->pdfminer3k>=1.3.1->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/f5/f1/5a93c118663896d83f7bcbfb7f657ce1d0c0d617e6b4a443a53abcc658ca/pluggy-0.7.1-py2.py3-none-any.whl
Collecting py>=1.5.0 (from pytest>=2.0->pdfminer3k>=1.3.1->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/c8/47/d179b80ab1dc1bfd46a0c87e391be47e6c7ef5831a9c138c5c49d1756288/py-1.6.0-py2.py3-none-any.whl
Collecting more-itertools>=4.0.0 (from pytest>=2.0->pdfminer3k>=1.3.1->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/79/b1/eace304ef66bd7d3d8b2f78cc374b73ca03bc53664d78151e9df3b3996cc/more_itertools-4.3.0-py3-none-any.whl
Collecting atomicwrites>=1.0 (from pytest>=2.0->pdfminer3k>=1.3.1->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/3a/9a/9d878f8d885706e2530402de6417141129a943802c084238914fa6798d97/atomicwrites-1.2.1-py2.py3-none-any.whl
Collecting oauthlib>=0.6.2 (from requests-oauthlib>=0.7.0->tweepy->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/e6/d1/ddd9cfea3e736399b97ded5c2dd62d1322adef4a72d816f1ed1049d6a179/oauthlib-2.1.0-py2.py3-none-any.whl
Requirement already satisfied: pytz in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from matplotlib>=2.0.0->Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: python-dateutil>=2.1 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from matplotlib>=2.0.0->Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from matplotlib>=2.0.0->Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: cycler>=0.10 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from matplotlib>=2.0.0->Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: kiwisolver>=1.0.1 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from matplotlib>=2.0.0->Orange3>=3.4.3->Orange3-Text)
Requirement already satisfied: decorator>=4.1.0 in /Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages (from networkx->Orange3>=3.4.3->Orange3-Text)
Collecting s3transfer<0.2.0,>=0.1.10 (from boto3->smart-open>=1.2.1->gensim>=0.12.3->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/d7/14/2a0004d487464d120c9fb85313a75cd3d71a7506955be458eebfe19a6b1d/s3transfer-0.1.13-py2.py3-none-any.whl
Collecting botocore<1.13.0,>=1.12.10 (from boto3->smart-open>=1.2.1->gensim>=0.12.3->Orange3-Text)
  Downloading https://files.pythonhosted.org/packages/17/c5/816a626efe96a3c90b1da3b7335ae6bdaa781b0de843ea93b642fc867e63/botocore-1.12.10-py2.py3-none-any.whl (4.7MB)
Collecting jmespath<1.0.0,>=0.7.1 (from boto3->smart-open>=1.2.1->gensim>=0.12.3->Orange3-Text)
  Using cached https://files.pythonhosted.org/packages/b7/31/05c8d001f7f87f0f07289a5fc0fc3832e9a57f2dbd4d3b0fee70e0d51365/jmespath-0.9.3-py2.py3-none-any.whl
Building wheels for collected packages: ufal.udpipe
  Running setup.py bdist_wheel for ufal.udpipe: started
  Running setup.py bdist_wheel for ufal.udpipe: finished with status 'error'
  Complete output from command /Applications/Orange3.app/Contents/MacOS/PythonApp -u -c "import setuptools, tokenize;__file__='/private/var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/pip-build-u086k99q/ufal.udpipe/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/tmpx3b2n8s2pip-wheel- --python-tag cp36:
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build/lib.macosx-10.6-intel-3.6
  creating build/lib.macosx-10.6-intel-3.6/ufal
  copying ufal/__init__.py -> build/lib.macosx-10.6-intel-3.6/ufal
  copying ufal/udpipe.py -> build/lib.macosx-10.6-intel-3.6/ufal
  running build_ext
  building 'ufal_udpipe' extension
  creating build/temp.macosx-10.6-intel-3.6
  creating build/temp.macosx-10.6-intel-3.6/udpipe
  /usr/bin/clang -fno-strict-aliasing -Wsign-compare -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch i386 -arch x86_64 -g -Iudpipe/include -I/Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/include/python3.6m -c udpipe/udpipe.cpp -o build/temp.macosx-10.6-intel-3.6/udpipe/udpipe.o -std=c++11 -fvisibility=hidden -w -stdlib=libc++
  clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
  clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
  error: command '/usr/bin/clang' failed with exit status 1

  ----------------------------------------
  Failed building wheel for ufal.udpipe
  Running setup.py clean for ufal.udpipe
Failed to build ufal.udpipe
Installing collected packages: biopython, beautifulsoup4, wikipedia, lxml, nltk, odfpy, simhash, setuptools-git, jmespath, botocore, s3transfer, boto3, boto, bz2file, smart-open, gensim, ufal.udpipe, attrs, pluggy, py, more-itertools, atomicwrites, pytest, ply, pdfminer3k, validate-email, PySocks, oauthlib, requests-oauthlib, tweepy, docx2txt, Orange3-Text
  Running setup.py install for ufal.udpipe: started
    Running setup.py install for ufal.udpipe: finished with status 'error'
    Complete output from command /Applications/Orange3.app/Contents/MacOS/PythonApp -u -c "import setuptools, tokenize;__file__='/private/var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/pip-build-u086k99q/ufal.udpipe/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/pip-_7k9lnza-record/install-record.txt --single-version-externally-managed --compile:
    running install
    running build
    running build_py
    creating build
    creating build/lib.macosx-10.6-intel-3.6
    creating build/lib.macosx-10.6-intel-3.6/ufal
    copying ufal/__init__.py -> build/lib.macosx-10.6-intel-3.6/ufal
    copying ufal/udpipe.py -> build/lib.macosx-10.6-intel-3.6/ufal
    running build_ext
    building 'ufal_udpipe' extension
    creating build/temp.macosx-10.6-intel-3.6
    creating build/temp.macosx-10.6-intel-3.6/udpipe
    /usr/bin/clang -fno-strict-aliasing -Wsign-compare -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch i386 -arch x86_64 -g -Iudpipe/include -I/Applications/Orange3.app/Contents/Frameworks/Python.framework/Versions/3.6/include/python3.6m -c udpipe/udpipe.cpp -o build/temp.macosx-10.6-intel-3.6/udpipe/udpipe.o -std=c++11 -fvisibility=hidden -w -stdlib=libc++
    clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
    clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
    error: command '/usr/bin/clang' failed with exit status 1

    ----------------------------------------
Command "/Applications/Orange3.app/Contents/MacOS/PythonApp -u -c "import setuptools, tokenize;__file__='/private/var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/pip-build-u086k99q/ufal.udpipe/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/pip-_7k9lnza-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/3q/1pftpjmn10g71rfc9p775sn80000gn/T/pip-build-u086k99q/ufal.udpipe/
You are using pip version 9.0.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
$\endgroup$
  • $\begingroup$ It should be fixed now. Those using Orange3 on Windows please make sure that you have Install add-ons with Conda checked in settings. $\endgroup$ – Primoz Oct 8 '18 at 10:58
  • $\begingroup$ I seem to be having this same issue. I've got "conda as installer" checked. I've completely uninstalled and reinstalled anaconda and orange to see if that made a difference. I still get the same issue that it won't install the text addon and keeps complaining about something with visual studio missing. Log snippet Building wheels for collected packages: ufal.udpipe Building wheel for ufal.udpipe (setup.py): started Building wheel for ufal.udpipe (setup.py): finished with status 'error' Complete output from command C:\Users\jeremyf\AppData\Local\Continuum\anaconda3\python.exe -u -c "import $\endgroup$ – JFennema Jan 28 '19 at 13:48
  • $\begingroup$ Use your orange3->option and click add-on... for choice of add-on to download and install. $\endgroup$ – Daniel Apr 3 '19 at 22:22
0
$\begingroup$

Yes, the latest version of Text was broken until recently, but should work now with the port of ufal.udpipe dependency to conda. For me it works on both platforms.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I still have issues, any guidance on how to remedy will be much appreciated. $\endgroup$ – Btibert3 Sep 27 '18 at 12:04
  • $\begingroup$ You would have to provide more information on what OS you are using and how you installed Orange. $\endgroup$ – vijolica Oct 3 '18 at 7:10
0
$\begingroup$

Same proble here. Then I went to https://github.com/biolab/orange3-text and installed via Anaconda as said, it was interrupted three times, but in the end all was installed, it even ran the transaction execution until the end, but when I opened Orange, no Text add-on there.

| improve this answer | |
$\endgroup$
  • $\begingroup$ It should be fixed now. Those using Orange3 on Windows please make sure that you have Install add-ons with Conda checked in settings. $\endgroup$ – Primoz Oct 8 '18 at 10:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.