-1
$\begingroup$

I installed the package "tidyverse", but when I am trying to run it, it give me this answer:

package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 0.2.1 is already loaded, but >= 0.3.0 is required

Could someone help me?

$\endgroup$
  • $\begingroup$ You are having version conflicts, always install all the independencies as well $\endgroup$ – Aditya Dec 3 '18 at 7:17
5
$\begingroup$

I solved the problem by the following way

  1. First updated R

    install.packages("installr")

    library(installr)

    updateR()

  2. Second install package ggplot2

    install.packages("ggplot2") // rlang install as a dependency with ggplot2

  3. Finally install package tidyverse

    install.packages("tidyverse")

Hope you can solve your problem by following the above way.

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.