0
$\begingroup$

I made a CNN on Keras with Tensorflow backend, my training set has 144 examples, but each example has size of 3200*101. My CNN is very basic, just for learning, batch_size of 2 (I tried reducing it from 32 but nothing improves). One CNN layer, one flatten layer and one dense layer for output (11 classes). When I fit the model, mi laptop shows "Allocation of (a big number) exceeds 10 of system memory" and then freeze it, even without running 1 epoch. I can't "compress" the examples, each of them must have that size exactly. I am running the model on CPU (I dont have GPU), 8 gb ram, 1 tb disk. What can I do?

Psdt: Sorry for any bad english, I am still learning. And thanks for any answer!

$\endgroup$
  • $\begingroup$ 10 what, 10%? is the answer not just that you need more memory? $\endgroup$ – Sean Owen Jan 11 at 20:08
  • $\begingroup$ 3200*101 pixels? That's pretty large I would say. I had this error two days ago and the reason was too many filters/units per in my convolutional layer or dense layer. After reducing the filters/units it worked fine. $\endgroup$ – ZWang Jan 16 at 18:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.