1
$\begingroup$

So I opened up a google cloud account and have access to global and local (us east 1) resources (Compute Engine API , NVIDIA K80 GPUs) and connected it to my dropbox.

Next, I followed this youtube video to try to connect it to my jupyter notebook.

The code to be entered into the google cloud platform is as follows:

sudo apt-get update
sudo apt-get - -assume-yes upgrade
sudo apt-get - -assume-yes install software-properties-common
sudo apt-get install python-setuptools python-dev build-essentials
sudo easy_install pip
sudo pip install jupyter
jupyter notebook - - generate-config
sudo nano ~/.jupyter/jupyter_notebook_config.py

Insert these following lines under #configuration file for jupyter notebook c=get_config()

c.NotebookApp.ip = ‘*’
c.NotebookApp.open_browser = False (or True)
c.NotebookApp.port=1000

ctrl+alt? enter ctrl+x? from 3.5.0.tar.gz you write tmux0.tar.gz ctrl+b shift+double_course (to get two diff windows) or exit to go out of the double

jupter notebook password
jupyter notebook –no-browser –port=1000

And then you go to your browser and write external ip:port (ex. 35.197.7.72:1000) At the top window, upload your environment

BUT, before running the following line:

sudo nano ~/.jupyter/jupter_notebook_config.py

It asks me if I want to overwrite .../jupyter/jupyte_notebook_config.py with default config, and with both scenarios (when entering yes and when entering no) after I run the line it says

sudo: nano: command not found

I even tried to pip install nano and it worked (the installation) but still the same response - anyone know what I should do?

$\endgroup$
  • $\begingroup$ I'm unable to flag this as being more appropriate for StackOverflow. $\endgroup$ – Wes Feb 18 '19 at 15:15
  • $\begingroup$ nano is a text editor. You can use whatever text editor available (vim, gedit, ...) to edit the config file. $\endgroup$ – user12075 Feb 19 '19 at 3:55
0
$\begingroup$

The python package nano is not the text editor you need. Instead, you need the Ubuntu package nano. Try:

$ sudo apt-get install nano
| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks! Now, I continue with the following code: 'sudo nano ~/.jupyter/jupyter_notebook_config.py' Insert these following lines under #configuration file for jupyter notebook c=get_config() c.NotebookApp.ip = ‘*’ c.NotebookApp.open_browser = False c.NotebookApp.port=1000 'jupyter-notebook --no-browser --port=1000' and it doesn't work (it did once this morning and since then, I've tried changing the port to 4000 or 5000 or 60) and the error I get is: socket.gaierror: [Errorno -2] Name or service not known Help, please? $\endgroup$ – Keren Feb 19 '19 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.