0
$\begingroup$

When I start Jupyter Lab or Notebook from the terminal, Azure Data Studio opens the auto-redirect HTML file instead of Firefox.

Is there a way to correct this behavior? I'm experiencing this issue on Ubuntu 18.04 on my personal computer, but do not see this behavior on my work computer, which is a Macbook Pro. Currently running Azure Data Studio 1.5.4.

jupyter                   1.0.0 
jupyter_client            5.2.4  
jupyter_console           6.0.0 
jupyter_core              4.4.0 
jupyterlab                0.35.3
jupyterlab_launcher       0.13.1
jupyterlab_server         0.2.0 

EDIT: After starting the HTML in ADS, this is the output I see in the terminal:

[main 11:17:33 PM] update#setState idle
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell
$\endgroup$
0
$\begingroup$

Changing the file ~/.config/mimeapps.list with settings to text/html=firefox.desktop fixed the issue. This issue is related to this one where other solutions are also provided (set a default browser for Jupyter).

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.