0
$\begingroup$

I am running Jupyter on a server on a virtual environment. I then tunnel my connection so I can access Jupyter on my browser.

When I SSH into the server, I can use the Panda module in both Ipython and Python3.

I ran this code in Ipython

 import pandas as pd                                                     

In [2]: print(pd.__file__)                                                      
/home/ubuntu/.local/lib/python3.6/site-packages/pandas/__init__.py

Then I tried adding it to my path in Jupyter with the code below, still no luck.

import os
os.getcwd() 
import sys
sys.path.append('/home/ubuntu/.local/lib/python3.6/site-packages/pandas/__init__.py')

import pandas as pd

I used these instructions to setup the Virtual Environment https://www.digitalocean.com/community/tutorials/how-to-set-up-jupyter-notebook-with-python-3-on-ubuntu-18-04

Thank you very much in advance, this will help me with my school studies a lot.

$\endgroup$
0
$\begingroup$

I had to start the virtual environment, then install pandas module

source virtual_enviornment_folder/bin/activate
pip install pandas
| improve this answer | |
$\endgroup$
  • $\begingroup$ You probably lacked dependencies to make pandas work in Jupyter (perhaps DataFrame display packages?) $\endgroup$ – Romain Reboulleau Nov 15 '19 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.