1
$\begingroup$

EDIT: Solution found.

Turns out the relations were set to Cross filter direction: Single on all relations (and the one from Month table.Month to A.Month was not set to active).

Setting Cross filter direction: Both fixed the problem.


I have four tables A, B, Month table and Quarter table

A has a column A.Month, and many other columns with irrelevant data

B has a column B.Quarter, and many other columns with irrelevant data

Month table has columns Month table.Month and Month table.Quarter

Quarter table has a column Quarter table.Quarter


One to many relations are shown as this: "<"

Quarter table.Quarter < Month table.Quarter as there are multiple (3) months in one quarter

Month table.Month < A.Month as there are several rows of data for each month

Quarter table.Quarter < B.Quarter as there are several rows of data for each quarter


Here is a visualisation of the relations

enter image description here


On my dashboard, I have a visual for A, and a visual for B

What I'm trying to do is to apply a page level filter with Month table.Month, thinking that therefore, A should only show data for whatever month/months are selected in the filter, and B should show the data for the corresponding quarter/quarters.


  • Filter to January

    Expectation:

    • A shows data for January
    • B shows data for Q1

    Reality:

    • A shows data for all months
    • B shows data for all quarters
  • Switch page level filter from Month table.Month to Quarter table.Quarter and set filter to Q1

    Expectation:

    • A shows data for January, February and Mars
    • B shows data for Q1

    Reality:

    • A shows data for all months
    • B shows data for Q1

What am I missing?

$\endgroup$
2
  • 1
    $\begingroup$ It is better to write an answer and mark it as correct if you solved it by yourself. $\endgroup$ Jun 19 '19 at 8:56
  • 1
    $\begingroup$ I tried to do that initially when I posted this but it wouldn't let me. Now I tried to undelete my old comment and it now suddenly let me mark my own answer as the solution. $\endgroup$
    – Zobtzler
    Aug 6 '19 at 13:37
1
$\begingroup$

Posting this as an answer.

Turns out the relations were set to Cross filter direction: Single on all relations (and the one from Month table.Month to A.Month was not set to active).

Setting Cross filter direction: Both fixed the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.