1
$\begingroup$

I tried installing PyFerret on my Macbook through the terminal. I got into my user directory with the terminal and gave it the following commands from this website https://anaconda.org/conda-forge/pyferret:

conda install -c conda-forge pyferret
conda install -c conda-forge/label/broken pyferret
conda install -c conda-forge/label/cf201901 pyferret

However, I noted that I only needed to download just one of them. I tried removing the files using

conda remove 
conda uninstall

but they did not work. Later I tried following the instructions from this website https://github.com/NOAA-PMEL/PyFerret/blob/master/README.md which instructs to type the following command

conda create -n FERRET -c conda-forge pyferret ferret_datasets --yes

then it says you can use PyFerret by calling it in the terminal as

conda activate FERRET

but the response I got was

CommandNotFoundError: Your shell has not been properly configured to use 'conda activate'.
To initialize your shell, run

    $ conda init <SHELL_NAME>

Currently supported shells are:
  - bash
  - fish
  - tcsh
  - xonsh
  - zsh
  - powershell

See 'conda init --help' for more information and options.

IMPORTANT: You may need to close and restart your shell after running 'conda init'.

I tried using

conda init -bash

and it sort of worked after that, I could use the command to activate PyFerret but it would only say PyFerrer on the name of my command line and I did not really know what was going on.

Could you please instruct me in how to uninstall everything? and if possible I would like to be instructed on how to get PyFerret to work as well.

$\endgroup$
1
$\begingroup$

It seems that Conda can only install one version of a package at a time,thus whatever installing command you use it will replace whatever other build you might have installed. So I reinstalled it using conda create -n FERRET -c conda-forge pyferret ferret_datasets --yes. After that I was able to activate the environment with conda activate FERRET If the terminal complains and asks you to initialize a shell, conda init bash should suffice to allow you to activate the environment.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.