2
$\begingroup$

I installed cuda-11.0 and cuDNN-8.2 and Tensor-RT 7.1. And then installed tensorflow-gpu. But tf.is_gpu_available() is showing False. Actually, I installed tensorflow-gpu first. I have pip3 20.1.1 and Nvidia GForce 930MX and Ubuntu 20.04.

Here is the nvidia-smi command output: enter image description here

$\endgroup$
4
  • $\begingroup$ You should provide more details, at least: operating system (linux/mac/windows), hardware (GPUs), method of installation (pip/conda) $\endgroup$
    – noe
    Jul 14, 2020 at 17:27
  • $\begingroup$ I added... @ncasas $\endgroup$ Jul 14, 2020 at 18:13
  • $\begingroup$ Can you include the output of command nvidia-smi? $\endgroup$
    – noe
    Jul 14, 2020 at 18:33
  • $\begingroup$ I did.. @ncasas $\endgroup$ Jul 14, 2020 at 18:42

3 Answers 3

1
$\begingroup$

Right now Tensorflow 2.1 doesn't support CUDA 11.0. Downgrade CUDA to version 10.1 and try again.

Reference: https://www.tensorflow.org/install/gpu

$\endgroup$
1
  • $\begingroup$ Having to downgrade is not acceptable. This sucks. $\endgroup$
    – fccoelho
    Nov 17, 2020 at 18:34
0
$\begingroup$

for macosx/linux tensorflow gpu installation - https://www.youtube.com/watch?v=MpUvdLD932c&list=PLjy4p-07OYzulelvJ5KVaT2pDlxivl_BN&index=8. for windows 10 - https://www.youtube.com/watch?v=qrkEYf-YDyI&list=PLjy4p-07OYzulelvJ5KVaT2pDlxivl_BN&index=9

$\endgroup$
0
$\begingroup$

Tensorflow could not found gpu because, the Cuda Toolkit version was 11. But, cuDNN version was 8.2RC + cuda 11. But in Tensorflow-2.2.0 it will work when cuda toolkit and cudnn both has cuda of version 10.1. Cuda 11.0 is not supported.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.