1
$\begingroup$

I am trying to run Tensorflows DeepLab using my own dataset, while following: heaversm tutorial on GitHub/Youtube.

P.S I am running Windows.

I want to run the model_test.py script (on my windows terminal - CMD) but it just returns the typical:

Traceback (most recent call last):
  File "model_test.py", line 21, in <module>
    from deeplab import common
ModuleNotFoundError: No module named 'deeplab'

I have installed all dependencies including tensorflow:

Name: tensorflow
Version: 2.3.1

I have also included (permenantly in the "Path" environment) the directories:

C:\Users\Name\Desktop\models-master\models-master\research\deeplab\
C:\Users\Name\Desktop\models-master\models-master\research\slim\
C:\Users\Name\Desktop\models-master\models-master\research\

But nothing worked when I decided to re-run model_test.py.

So I then decided to temporarily set a environment variable named PYTHONPATH with the following (as the tutorial mentions):

# Making sure I am in the models\research directory (as per the tutorial)
# In my case it is models-master\research directory 
export PYTHONPATH=$PYTHONPATH:`pwd`:`pwd`/slim  # --> macOS version
set PYTHONPATH=%PYTHONPATH%;%cd%;%cd%/slim  # --> Windows version

Again nothing worked... I am running out of options and hope.

Am i doing anything wrong here?? Am i missing a certain folder maybe?

Any help would be appreciated.

$\endgroup$
0
$\begingroup$

You need to start you program from the models/research repository (cd ./models/research before executing)

$\endgroup$
2
  • $\begingroup$ Have tried that. I also mention this in my question $\endgroup$ – Kamal Raydan Dec 3 '20 at 11:33
  • $\begingroup$ I’m not speaking about setting variable. I sugest to launch your training from the models/research directory. $\endgroup$ – Chopin Dec 3 '20 at 12:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.